openssh.spec revision 296781
1%define ver 7.2p2
2%define rel 1
3
4# OpenSSH privilege separation requires a user & group ID
5%define sshd_uid    74
6%define sshd_gid    74
7
8# Version of ssh-askpass
9%define aversion 1.2.4.1
10
11# Do we want to disable building of x11-askpass? (1=yes 0=no)
12%define no_x11_askpass 0
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Do we want to link against a static libcrypto? (1=yes 0=no)
18%define static_libcrypto 0
19
20# Do we want smartcard support (1=yes 0=no)
21%define scard 0
22
23# Use GTK2 instead of GNOME in gnome-ssh-askpass
24%define gtk2 1
25
26# Is this build for RHL 6.x?
27%define build6x 0
28
29# Do we want kerberos5 support (1=yes 0=no)
30%define kerberos5 1
31
32# Reserve options to override askpass settings with:
33# rpm -ba|--rebuild --define 'skip_xxx 1'
34%{?skip_x11_askpass:%define no_x11_askpass 1}
35%{?skip_gnome_askpass:%define no_gnome_askpass 1}
36
37# Add option to build without GTK2 for older platforms with only GTK+.
38# RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
39# rpm -ba|--rebuild --define 'no_gtk2 1'
40%{?no_gtk2:%define gtk2 0}
41
42# Is this a build for RHL 6.x or earlier?
43%{?build_6x:%define build6x 1}
44
45# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
46%if %{build6x}
47%define _sysconfdir /etc
48%endif
49
50# Options for static OpenSSL link:
51# rpm -ba|--rebuild --define "static_openssl 1"
52%{?static_openssl:%define static_libcrypto 1}
53
54# Options for Smartcard support: (needs libsectok and openssl-engine)
55# rpm -ba|--rebuild --define "smartcard 1"
56%{?smartcard:%define scard 1}
57
58# Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
59%define rescue 0
60%{?build_rescue:%define rescue 1}
61
62# Turn off some stuff for resuce builds
63%if %{rescue}
64%define kerberos5 0
65%endif
66
67Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
68Name: openssh
69Version: %{ver}
70%if %{rescue}
71Release: %{rel}rescue
72%else
73Release: %{rel}
74%endif
75URL: http://www.openssh.com/portable.html
76Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
77%if ! %{no_x11_askpass}
78Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
79%endif
80License: BSD
81Group: Applications/Internet
82BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
83Obsoletes: ssh
84%if %{build6x}
85PreReq: initscripts >= 5.00
86%else
87Requires: initscripts >= 5.20
88%endif
89BuildRequires: perl, openssl-devel
90BuildRequires: /bin/login
91%if ! %{build6x}
92BuildRequires: glibc-devel, pam
93%else
94BuildRequires: /usr/include/security/pam_appl.h
95%endif
96%if ! %{no_x11_askpass}
97BuildRequires: /usr/include/X11/Xlib.h
98%endif
99%if ! %{no_gnome_askpass}
100BuildRequires: pkgconfig
101%endif
102%if %{kerberos5}
103BuildRequires: krb5-devel
104BuildRequires: krb5-libs
105%endif
106
107%package clients
108Summary: OpenSSH clients.
109Requires: openssh = %{version}-%{release}
110Group: Applications/Internet
111Obsoletes: ssh-clients
112
113%package server
114Summary: The OpenSSH server daemon.
115Group: System Environment/Daemons
116Obsoletes: ssh-server
117Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
118%if ! %{build6x}
119Requires: /etc/pam.d/system-auth
120%endif
121
122%package askpass
123Summary: A passphrase dialog for OpenSSH and X.
124Group: Applications/Internet
125Requires: openssh = %{version}-%{release}
126Obsoletes: ssh-extras
127
128%package askpass-gnome
129Summary: A passphrase dialog for OpenSSH, X, and GNOME.
130Group: Applications/Internet
131Requires: openssh = %{version}-%{release}
132Obsoletes: ssh-extras
133
134%description
135SSH (Secure SHell) is a program for logging into and executing
136commands on a remote machine. SSH is intended to replace rlogin and
137rsh, and to provide secure encrypted communications between two
138untrusted hosts over an insecure network. X11 connections and
139arbitrary TCP/IP ports can also be forwarded over the secure channel.
140
141OpenSSH is OpenBSD's version of the last free version of SSH, bringing
142it up to date in terms of security and features, as well as removing
143all patented algorithms to separate libraries.
144
145This package includes the core files necessary for both the OpenSSH
146client and server. To make this package useful, you should also
147install openssh-clients, openssh-server, or both.
148
149%description clients
150OpenSSH is a free version of SSH (Secure SHell), a program for logging
151into and executing commands on a remote machine. This package includes
152the clients necessary to make encrypted connections to SSH servers.
153You'll also need to install the openssh package on OpenSSH clients.
154
155%description server
156OpenSSH is a free version of SSH (Secure SHell), a program for logging
157into and executing commands on a remote machine. This package contains
158the secure shell daemon (sshd). The sshd daemon allows SSH clients to
159securely connect to your SSH server. You also need to have the openssh
160package installed.
161
162%description askpass
163OpenSSH is a free version of SSH (Secure SHell), a program for logging
164into and executing commands on a remote machine. This package contains
165an X11 passphrase dialog for OpenSSH.
166
167%description askpass-gnome
168OpenSSH is a free version of SSH (Secure SHell), a program for logging
169into and executing commands on a remote machine. This package contains
170an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
171environment.
172
173%prep
174
175%if ! %{no_x11_askpass}
176%setup -q -a 1
177%else
178%setup -q
179%endif
180
181%build
182%if %{rescue}
183CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
184%endif
185
186%if %{kerberos5}
187K5DIR=`rpm -ql krb5-devel | grep 'include/krb5\.h' | sed 's,\/include\/krb5.h,,'`
188echo K5DIR=$K5DIR
189%endif
190
191%configure \
192	--sysconfdir=%{_sysconfdir}/ssh \
193	--libexecdir=%{_libexecdir}/openssh \
194	--datadir=%{_datadir}/openssh \
195	--with-default-path=/usr/local/bin:/bin:/usr/bin \
196	--with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
197	--with-privsep-path=%{_var}/empty/sshd \
198	--with-md5-passwords \
199%if %{scard}
200	--with-smartcard \
201%endif
202%if %{rescue}
203	--without-pam \
204%else
205	--with-pam \
206%endif
207%if %{kerberos5}
208	 --with-kerberos5=$K5DIR \
209%endif
210
211
212%if %{static_libcrypto}
213perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
214%endif
215
216make
217
218%if ! %{no_x11_askpass}
219pushd x11-ssh-askpass-%{aversion}
220%configure --libexecdir=%{_libexecdir}/openssh
221xmkmf -a
222make
223popd
224%endif
225
226# Define a variable to toggle gnome1/gtk2 building.  This is necessary
227# because RPM doesn't handle nested %if statements.
228%if %{gtk2}
229	gtk2=yes
230%else
231	gtk2=no
232%endif
233
234%if ! %{no_gnome_askpass}
235pushd contrib
236if [ $gtk2 = yes ] ; then
237	make gnome-ssh-askpass2
238	mv gnome-ssh-askpass2 gnome-ssh-askpass
239else
240	make gnome-ssh-askpass1
241	mv gnome-ssh-askpass1 gnome-ssh-askpass
242fi
243popd
244%endif
245
246%install
247rm -rf $RPM_BUILD_ROOT
248mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
249mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
250mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
251
252make install DESTDIR=$RPM_BUILD_ROOT
253
254install -d $RPM_BUILD_ROOT/etc/pam.d/
255install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
256install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
257%if %{build6x}
258install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
259%else
260install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
261%endif
262install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
263
264%if ! %{no_x11_askpass}
265install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
266ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
267%endif
268
269%if ! %{no_gnome_askpass}
270install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
271%endif
272
273%if ! %{scard}
274	 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
275%endif
276
277%if ! %{no_gnome_askpass}
278install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
279install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
280install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
281%endif
282
283perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
284
285%clean
286rm -rf $RPM_BUILD_ROOT
287
288%triggerun server -- ssh-server
289if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
290	touch /var/run/sshd.restart
291fi
292
293%triggerun server -- openssh-server < 2.5.0p1
294# Count the number of HostKey and HostDsaKey statements we have.
295gawk	'BEGIN {IGNORECASE=1}
296	 /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
297	 END {exit sawhostkey}' /etc/ssh/sshd_config
298# And if we only found one, we know the client was relying on the old default
299# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
300# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
301# one nullifies the default, which would have loaded both.
302if [ $? -eq 1 ] ; then
303	echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
304	echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
305fi
306
307%triggerpostun server -- ssh-server
308if [ "$1" != 0 ] ; then
309	/sbin/chkconfig --add sshd
310	if test -f /var/run/sshd.restart ; then
311		rm -f /var/run/sshd.restart
312		/sbin/service sshd start > /dev/null 2>&1 || :
313	fi
314fi
315
316%pre server
317%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
318%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
319	-g sshd -M -r sshd 2>/dev/null || :
320
321%post server
322/sbin/chkconfig --add sshd
323
324%postun server
325/sbin/service sshd condrestart > /dev/null 2>&1 || :
326
327%preun server
328if [ "$1" = 0 ]
329then
330	/sbin/service sshd stop > /dev/null 2>&1 || :
331	/sbin/chkconfig --del sshd
332fi
333
334%files
335%defattr(-,root,root)
336%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
337%attr(0755,root,root) %{_bindir}/scp
338%attr(0644,root,root) %{_mandir}/man1/scp.1*
339%attr(0755,root,root) %dir %{_sysconfdir}/ssh
340%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
341%if ! %{rescue}
342%attr(0755,root,root) %{_bindir}/ssh-keygen
343%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
344%attr(0755,root,root) %dir %{_libexecdir}/openssh
345%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
346%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
347%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
348%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
349%endif
350%if %{scard}
351%attr(0755,root,root) %dir %{_datadir}/openssh
352%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
353%endif
354
355%files clients
356%defattr(-,root,root)
357%attr(0755,root,root) %{_bindir}/ssh
358%attr(0644,root,root) %{_mandir}/man1/ssh.1*
359%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
360%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
361%attr(-,root,root) %{_bindir}/slogin
362%attr(-,root,root) %{_mandir}/man1/slogin.1*
363%if ! %{rescue}
364%attr(2755,root,nobody) %{_bindir}/ssh-agent
365%attr(0755,root,root) %{_bindir}/ssh-add
366%attr(0755,root,root) %{_bindir}/ssh-keyscan
367%attr(0755,root,root) %{_bindir}/sftp
368%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
369%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
370%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
371%attr(0644,root,root) %{_mandir}/man1/sftp.1*
372%endif
373
374%if ! %{rescue}
375%files server
376%defattr(-,root,root)
377%dir %attr(0111,root,root) %{_var}/empty/sshd
378%attr(0755,root,root) %{_sbindir}/sshd
379%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
380%attr(0644,root,root) %{_mandir}/man8/sshd.8*
381%attr(0644,root,root) %{_mandir}/man5/moduli.5*
382%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
383%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
384%attr(0755,root,root) %dir %{_sysconfdir}/ssh
385%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
386%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
387%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
388%endif
389
390%if ! %{no_x11_askpass}
391%files askpass
392%defattr(-,root,root)
393%doc x11-ssh-askpass-%{aversion}/README
394%doc x11-ssh-askpass-%{aversion}/ChangeLog
395%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
396%attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
397%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
398%endif
399
400%if ! %{no_gnome_askpass}
401%files askpass-gnome
402%defattr(-,root,root)
403%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
404%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
405%endif
406
407%changelog
408* Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
409- test for skip_x11_askpass (line 77) should have been for no_x11_askpass
410
411* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
412- Remove noip6 option. This may be controlled at run-time in client config
413  file using new AddressFamily directive
414
415* Mon May 12 2003 Damien Miller <djm@mindrot.org>
416- Don't install profile.d scripts when not building with GNOME/GTK askpass
417  (patch from bet@rahul.net)
418
419* Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
420- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
421
422* Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
423- Use contrib/ Makefile for building askpass programs
424
425* Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
426- Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
427- Add new {ssh,sshd}_config.5 manpages
428- Add new ssh-keysign program and remove setuid from ssh client
429
430* Fri May 10 2002 Damien Miller <djm@mindrot.org>
431- Merge in spec changes from RedHat, reorgansie a little
432- Add Privsep user, group and directory
433
434* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
435- bump and grind (through the build system)
436
437* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
438- require sharutils for building (mindrot #137)
439- require db1-devel only when building for 6.x (#55105), which probably won't
440  work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
441- require pam-devel by file (not by package name) again
442- add Markus's patch to compile with OpenSSL 0.9.5a (from
443  http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
444  building for 6.x
445
446* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
447- update to 3.1p1
448
449* Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
450- update to SNAP-20020305
451- drop debug patch, fixed upstream
452
453* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
454- update to SNAP-20020220 for testing purposes (you've been warned, if there's
455  anything to be warned about, gss patches won't apply, I don't mind)
456
457* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
458- add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
459  exchange, authentication, and named key support
460
461* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
462- remove dependency on db1-devel, which has just been swallowed up whole
463  by gnome-libs-devel
464
465* Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
466- adjust build dependencies so that build6x actually works right (fix
467  from Hugo van der Kooij)
468
469* Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
470- update to 3.0.2p1
471
472* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
473- update to 3.0.1p1
474
475* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
476- update to current CVS (not for use in distribution)
477
478* Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
479- merge some of Damien Miller <djm@mindrot.org> changes from the upstream
480  3.0p1 spec file and init script
481
482* Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
483- update to 3.0p1
484- update to x11-ssh-askpass 1.2.4.1
485- change build dependency on a file from pam-devel to the pam-devel package
486- replace primes with moduli
487
488* Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
489- incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
490
491* Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
492- Merge changes to rescue build from current sysadmin survival cd
493
494* Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
495- fix scp's server's reporting of file sizes, and build with the proper
496  preprocessor define to get large-file capable open(), stat(), etc.
497  (sftp has been doing this correctly all along) (#51827)
498- configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
499- pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
500- mark profile.d scriptlets as config files (#42337)
501- refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
502- change a couple of log() statements to debug() statements (#50751)
503- pull cvs patch to add -t flag to sshd (#28611)
504- clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
505
506* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
507- add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
508
509* Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
510- pull cvs patch to fix remote port forwarding with protocol 2
511
512* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
513- pull cvs patch to add session initialization to no-pty sessions
514- pull cvs patch to not cut off challengeresponse auth needlessly
515- refuse to do X11 forwarding if xauth isn't there, handy if you enable
516  it by default on a system that doesn't have X installed (#49263)
517
518* Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
519- don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
520
521* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
522- pass OPTIONS correctly to initlog (#50151)
523
524* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
525- switch to x11-ssh-askpass 1.2.2
526
527* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
528- rebuild in new environment
529
530* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
531- disable the gssapi patch
532
533* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
534- update to 2.9p2
535- refresh to a new version of the gssapi patch
536
537* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
538- change Copyright: BSD to License: BSD
539- add Markus Friedl's unverified patch for the cookie file deletion problem
540  so that we can verify it
541- drop patch to check if xauth is present (was folded into cookie patch)
542- don't apply gssapi patches for the errata candidate
543- clear supplemental groups list at startup
544
545* Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
546- fix an error parsing the new default sshd_config
547- add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
548  dealing with comments right
549
550* Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
551- add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
552  to be removed before the next beta cycle because it's a big departure
553  from the upstream version
554
555* Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
556- finish marking strings in the init script for translation
557- modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
558  at startup (change merged from openssh.com init script, originally by
559  Pekka Savola)
560- refuse to do X11 forwarding if xauth isn't there, handy if you enable
561  it by default on a system that doesn't have X installed
562
563* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
564- update to 2.9
565- drop various patches that came from or went upstream or to or from CVS
566
567* Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
568- only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
569
570* Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
571- remove explicit openssl requirement, fixes builddistro issue
572- make initscript stop() function wait until sshd really dead to avoid
573  races in condrestart
574
575* Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
576- mention that challengereponse supports PAM, so disabling password doesn't
577  limit users to pubkey and rsa auth (#34378)
578- bypass the daemon() function in the init script and call initlog directly,
579  because daemon() won't start a daemon it detects is already running (like
580  open connections)
581- require the version of openssl we had when we were built
582
583* Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
584- make do_pam_setcred() smart enough to know when to establish creds and
585  when to reinitialize them
586- add in a couple of other fixes from Damien for inclusion in the errata
587
588* Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
589- update to 2.5.2p2
590- call setcred() again after initgroups, because the "creds" could actually
591  be group memberships
592
593* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
594- update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
595- don't enable challenge-response by default until we find a way to not
596  have too many userauth requests (we may make up to six pubkey and up to
597  three password attempts as it is)
598- remove build dependency on rsh to match openssh.com's packages more closely
599
600* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
601- remove dependency on openssl -- would need to be too precise
602
603* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
604- rebuild in new environment
605
606* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
607- Revert the patch to move pam_open_session.
608- Init script and spec file changes from Pekka Savola. (#28750)
609- Patch sftp to recognize '-o protocol' arguments. (#29540)
610
611* Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
612- Chuck the closing patch.
613- Add a trigger to add host keys for protocol 2 to the config file, now that
614  configuration file syntax requires us to specify it with HostKey if we
615  specify any other HostKey values, which we do.
616
617* Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
618- Redo patch to move pam_open_session after the server setuid()s to the user.
619- Rework the nopam patch to use be picked up by autoconf.
620
621* Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
622- Update for 2.5.1p1.
623- Add init script mods from Pekka Savola.
624- Tweak the init script to match the CVS contrib script more closely.
625- Redo patch to ssh-add to try to adding both identity and id_dsa to also try
626  adding id_rsa.
627
628* Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
629- Update for 2.5.0p1.
630- Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
631- Resync with parts of Damien Miller's openssh.spec from CVS, including
632  update of x11 askpass to 1.2.0.
633- Only require openssl (don't prereq) because we generate keys in the init
634  script now.
635
636* Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
637- Don't open a PAM session until we've forked and become the user (#25690).
638- Apply Andrew Bartlett's patch for letting pam_authenticate() know which
639  host the user is attempting a login from.
640- Resync with parts of Damien Miller's openssh.spec from CVS.
641- Don't expose KbdInt responses in debug messages (from CVS).
642- Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
643
644* Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
645- i18n-tweak to initscript.
646
647* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
648- More gettextizing.
649- Close all files after going into daemon mode (needs more testing).
650- Extract patch from CVS to handle auth banners (in the client).
651- Extract patch from CVS to handle compat weirdness.
652
653* Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
654- Finish with the gettextizing.
655
656* Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
657- Fix a bug in auth2-pam.c (#23877)
658- Gettextize the init script.
659
660* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
661- Incorporate a switch for using PAM configs for 6.x, just in case.
662
663* Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
664- Incorporate Bero's changes for a build specifically for rescue CDs.
665
666* Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
667- Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
668  succeeded, to allow public-key authentication after a failure with "none"
669  authentication.  (#21268)
670
671* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
672- Update to x11-askpass 1.1.1. (#21301)
673- Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
674
675* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
676- Merge multiple PAM text messages into subsequent prompts when possible when
677  doing keyboard-interactive authentication.
678
679* Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
680- Disable the built-in MD5 password support.  We're using PAM.
681- Take a crack at doing keyboard-interactive authentication with PAM, and
682  enable use of it in the default client configuration so that the client
683  will try it when the server disallows password authentication.
684- Build with debugging flags.  Build root policies strip all binaries anyway.
685
686* Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
687- Use DESTDIR instead of %%makeinstall.
688- Remove /usr/X11R6/bin from the path-fixing patch.
689
690* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
691- Add the primes file from the latest snapshot to the main package (#20884).
692- Add the dev package to the prereq list (#19984).
693- Remove the default path and mimic login's behavior in the server itself.
694
695* Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
696- Resync with conditional options in Damien Miller's .spec file for an errata.
697- Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
698
699* Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
700- Update to OpenSSH 2.3.0p1.
701- Update to x11-askpass 1.1.0.
702- Enable keyboard-interactive authentication.
703
704* Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
705- Update to ssh-askpass-x11 1.0.3.
706- Change authentication related messages to be private (#19966).
707
708* Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
709- Patch ssh-keygen to be able to list signatures for DSA public key files
710  it generates.
711
712* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
713- Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
714  build PAM authentication in.
715- Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
716- Clean out no-longer-used patches.
717- Patch ssh-add to try to add both identity and id_dsa, and to error only
718  when neither exists.
719
720* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
721- Update x11-askpass to 1.0.2. (#17835)
722- Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
723  always find them in the right place. (#17909)
724- Set the default path to be the same as the one supplied by /bin/login, but
725  add /usr/X11R6/bin. (#17909)
726- Try to handle obsoletion of ssh-server more cleanly.  Package names
727  are different, but init script name isn't. (#17865)
728
729* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
730- Update to 2.2.0p1. (#17835)
731- Tweak the init script to allow proper restarting. (#18023)
732
733* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
734- Update to 20000823 snapshot.
735- Change subpackage requirements from %%{version} to %%{version}-%%{release}
736- Back out the pipe patch.
737
738* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
739- Update to 2.1.1p4, which includes fixes for config file parsing problems.
740- Move the init script back.
741- Add Damien's quick fix for wackiness.
742
743* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
744- Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
745
746* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
747- Move condrestart to server postun.
748- Move key generation to init script.
749- Actually use the right patch for moving the key generation to the init script.
750- Clean up the init script a bit.
751
752* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
753- Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
754
755* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
756- Update to 2.1.1p2.
757- Use of strtok() considered harmful.
758
759* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
760- Get the build root out of the man pages.
761
762* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
763- Add and use condrestart support in the init script.
764- Add newer initscripts as a prereq.
765
766* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
767- Build in new environment (release 2)
768- Move -clients subpackage to Applications/Internet group
769
770* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
771- Update to 2.2.1p1
772
773* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
774- Patch to build with neither RSA nor RSAref.
775- Miscellaneous FHS-compliance tweaks.
776- Fix for possibly-compressed man pages.
777
778* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
779- Updated for new location
780- Updated for new gnome-ssh-askpass build
781
782* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
783- Added Jim Knoble's <jmknoble@pobox.com> askpass
784
785* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
786- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
787
788* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
789- Added 'Obsoletes' directives
790
791* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
792- Use make install
793- Subpackages
794
795* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
796- Added links for slogin
797- Fixed perms on manpages
798
799* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
800- Renamed init script
801
802* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
803- Back to old binary names
804
805* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
806- Use autoconf
807- New binary names
808
809* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
810- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
811