mingw-byacc.spec revision 272957
1Summary: byacc - public domain Berkeley LALR Yacc parser generator
2%define AppProgram byacc
3%define AppVersion 20141006
4%define UseProgram yacc
5# $XTermId: mingw-byacc.spec,v 1.7 2014/10/06 22:52:03 tom Exp $
6Name: %{AppProgram}
7Version: %{AppVersion}
8Release: 1
9License: Public Domain, MIT
10Group: Applications/Development
11URL: ftp://invisible-island.net/%{AppProgram}
12Source0: %{AppProgram}-%{AppVersion}.tgz
13Packager: Thomas Dickey <dickey@invisible-island.net>
14
15%description
16This package provides a parser generator utility that reads a grammar
17specification from a file and generates an LR(1) parser for it.  The
18parsers consist of a set of LALR(1) parsing tables and a driver
19routine written in the C programming language.  It has a public domain
20license which includes the generated C.
21
22%prep
23
24%setup -q -n %{AppProgram}-%{AppVersion}
25
26%build
27
28INSTALL_PROGRAM='${INSTALL}' \
29	./configure \
30		--program-prefix=b \
31		--target %{_target_platform} \
32		--prefix=%{_prefix} \
33		--bindir=%{_bindir} \
34		--libdir=%{_libdir} \
35		--mandir=%{_mandir}
36
37make
38
39%install
40[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41
42make install                    DESTDIR=$RPM_BUILD_ROOT
43( cd $RPM_BUILD_ROOT%{_bindir} && ln -s %{AppProgram} %{UseProgram} )
44
45strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
46
47%clean
48[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(-,root,root)
52%{_prefix}/bin/%{AppProgram}
53%{_prefix}/bin/%{UseProgram}
54%{_mandir}/man1/%{AppProgram}.*
55
56%changelog
57# each patch should add its ChangeLog entries here
58
59* Wed Sep 25 2013 Thomas Dickey
60- cloned from byacc.spec
61