mingw-byacc.spec revision 272953
1272343SngieSummary: byacc - public domain Berkeley LALR Yacc parser generator
2272343Sngie%define AppProgram byacc
3272343Sngie%define AppVersion 20140715
4272343Sngie%define UseProgram yacc
5272343Sngie# $XTermId: mingw-byacc.spec,v 1.4 2014/07/15 19:36:54 tom Exp $
6272343SngieName: %{AppProgram}
7272343SngieVersion: %{AppVersion}
8272343SngieRelease: 1
9272343SngieLicense: Public Domain, MIT
10272343SngieGroup: Applications/Development
11272343SngieURL: ftp://invisible-island.net/%{AppProgram}
12272343SngieSource0: %{AppProgram}-%{AppVersion}.tgz
13272343SngiePackager: Thomas Dickey <dickey@invisible-island.net>
14272343Sngie
15272343Sngie%description
16272343SngieThis package provides a parser generator utility that reads a grammar
17272343Sngiespecification from a file and generates an LR(1) parser for it.  The
18272343Sngieparsers consist of a set of LALR(1) parsing tables and a driver
19272343Sngieroutine written in the C programming language.  It has a public domain
20272343Sngielicense which includes the generated C.
21272343Sngie
22272343Sngie%prep
23272343Sngie
24272343Sngie%setup -q -n %{AppProgram}-%{AppVersion}
25272343Sngie
26272343Sngie%build
27272343Sngie
28272343SngieINSTALL_PROGRAM='${INSTALL}' \
29272343Sngie	./configure \
30272343Sngie		--program-prefix=b \
31272343Sngie		--target %{_target_platform} \
32272343Sngie		--prefix=%{_prefix} \
33272343Sngie		--bindir=%{_bindir} \
34272343Sngie		--libdir=%{_libdir} \
35272343Sngie		--mandir=%{_mandir}
36272343Sngie
37272343Sngiemake
38272343Sngie
39272343Sngie%install
40272343Sngie[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41272343Sngie
42272343Sngiemake install                    DESTDIR=$RPM_BUILD_ROOT
43272343Sngie( cd $RPM_BUILD_ROOT%{_bindir} && ln -s %{AppProgram} %{UseProgram} )
44272343Sngie
45272343Sngiestrip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
46272343Sngie
47272343Sngie%clean
48272343Sngie[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
49272343Sngie
50272343Sngie%files
51272343Sngie%defattr(-,root,root)
52272343Sngie%{_prefix}/bin/%{AppProgram}
53272343Sngie%{_prefix}/bin/%{UseProgram}
54272343Sngie%{_mandir}/man1/%{AppProgram}.*
55272343Sngie
56272343Sngie%changelog
57272343Sngie# each patch should add its ChangeLog entries here
58272343Sngie
59272343Sngie* Wed Sep 25 2013 Thomas Dickey
60272343Sngie- cloned from byacc.spec
61272343Sngie